• Hi Guest! To get rid of ads on the page, please consider donating through user upgrades or other methods.

My BnsBuddy run like shit

Not open for further replies.


I tried everything I could think of to get this game to work with BnsBuddy. I tried

- Nvidia Control panel (Yes everything that I have seen on forums has been done)
- Properties Compatibility
- In game setting
- Custom KR Nvidia setting
- Unlock core
- Clear memory task
- Reset Nvidia setting
- Set priority High
- Config path

Before you say well maybe your hardware is shit I upgrade from
FX processor to Ryzen 7
1050Ti to 1070
and the game ran off of an SSD to M.2
and went from a 64bit processor to a 32bit processor

Note that BnsBuddy ran like a charm on my older hardware

I can run both 32 and 64 fine with exception of random crashes which BnsBuddy did a great job of preventing. It also helps me enable and disable mods on the fly.

The main problem stems from 32bit version having FPS dropping from 125 to 12 everytime I'm fighting a boss inside a dungeon and the 64bit being cap at 25 FPS. For some reason, BnsBuddy does not use all power CPU and GPU can give it.

For comparison 32bit run at 125 and 80~60 while in combat and 64bit about the same

If someone knows a solution please let me know so far the only thing I can think of is that BnsBuddy just does not like 32Bit

P.S. Haven't really used bnsbuddy from so sorry if this ends up in the wrong place
Last edited:


Staff member
1: Your fps being capped can be related to FTH and/or NVIDIA profile for bns being broken.

To fix this: Disable fth via registry & and clear the entry for "Client.exe" / for nvidia go here:
2: BnS Buddy itself never uses all gpu/cpu because it ain't the game itself.

3: A Processor doesn't go itself from 64bit to 32bit. It's illogical and impossible. If you want to run 64bit Client.exe from buddy it allows you to do both.

4: Uninstall all previously old drivers and delete all old configs that may have been applied in msconfig for cores to use all your new cores, unparked, set a power plan by ryzen and clock it to the max using Ryzen Master software given by AMD to overclock.

5: FPS Drops occurs due to the settings you setted ingame, turn down shadows. That should help alot, you can't get past 120 fps because your fps is capped in the game settings located via documents path.


set it to 0 to uncap frames before launching the game via bns buddy.


Finally, don't blame the software if the optimizations on user side weren't done/applied properly. Thank you.

PS: Let's hope this works for you.

frank toronto

BnS buddy doesn't really make the game use either the CPU or the GPU; it's more like it forces the client to recognize that the additional CPU cores are existent. As for the GPU, well I remember upgrading from an GT320 to an GTX770SC about 2 years ago and saw less than 5 fps difference; goes to show just how much the GPU is actually used.

Not sure what you mean by going from an 64bit CPU to an 32bit; since both the FX and RYZEN are X64. If you installed the X32 bit version of windows on your new PC, reformat your drive and start over with the 64bit version.
Having Just upgraded myself from an First gen A8 processor (socket FM1) to a second gen RYZEN 5 (RYSEN 5 2600, 6 cores running at 3.85GHz) I can confirm that you should be getting 120fps (the game's cap) out of combat and about 80fps at the lowest in a 6 man party (all settings at 4).

If you bought a ready made gaming PC I would recommend looking for bloatware.


Finally, don't blame the software if the optimizations on user side weren't done/applied properly. Thank you.

PS: Let's hope this works for you.

I know the in-game sitting effect the rate of your fps I just wanted them to mirror each other their no reason BnsBuddy should bring my frame rate down. Besides that I forgot about the stupid Client.exe D: I tend to always fresh install whenever upgrading any of the hardware with the exception of copy paste my games. Client.exe Reeeeeeeeeeeeeeeeeeeee when I saw that at the starting of video all could think of is I feel stupid. :bnsshy2: Anyway thanks for the help been at this for been. at this for six days time Mod.:bnspassion:

BnsBuddy #:bnsfinger:
Not open for further replies.
Top Bottom