• Hi Guest! To get rid of ads on the page, please consider donating through user upgrades or other methods.

Personal UE4 Bug tracker

Not open for further replies.


Staff member
This post is for me to track all bugs I know of, including if they were fixed or not.

The BnS forum currently has over 300 messages, but as of 21st September 2021, almost none were worked on.

This should help people to find specific UE4 bugs, before reporting them, as well as showing to NCSoft/NCWest what is missing.
(Not that they will listen, but well, the community needs this).

I will separate the bugs into existing and fixed bugs, and will only link the first instance of each bugs.
Some bugs are repeated 10-20 times (like the AZERTY bug and the Call for Arms Pet Gems not having stats).
Other bugs that are omitted are bugs that make no sense to me, or I see they aren't bugs at all.
Others (like the Call for Arms Pet Gems not having stats and the Realmrift Supply Chain camera bug) are event specific and won't be included.

- Bugs reported by the community
(Why distinguish them? Well, can't I have some credit for finding bugs by myself? Also, I want the community to take credit too.)

Only will follow bugs posted in here - https://forums.bladeandsoul.com/topic/252194-report-ue4-bugs-here/

Existing bugs - 161 bugs


  • Viridian Coast - Everdusk - Shadow and lightning bugs around the well area - link

  • Viridian Coast - Jadestone village - The light flashes on certain spots - link

Game breaking bugs - 11 bugs

Bugs that prevent you from playing, advancing on quests and others.
If it affects the ability to play the game, it will be here.

  • Gamepad doesn't work - link
    A post was made in the forum, saying the game has to be re-worked to add support for gamepads - link
    This can cause problems with people that have physical disabilities, which makes it impossible for them to play the game.

  • Text is unreadable - link
    This can cause problems for people with visual problems.
    Even those that have no problems seeing do have problems reading the micro font size used ingame.

  • Changing resolution causes fps to plummet - link
    This can make the game to run at 1 fps, rendering the game unplayable.
    Major bug " Fullscreen options and resolution do not work".

  • Game Sound output Defaults to Oculus Virtual Audio Device which tanks framerate - link
    This can make the game to run at 1 fps, rendering the game unplayable.

  • Howl of the Hound quest cannot be finished - link

  • Act III chapter 27 - Stuck without UI after cutscene - link

  • First letter from Hajoon (Purple) - Cinematic doesn't launch after parade tutorial, and the game gets stuck with default mesh - link

  • Quest "harder, better, faster, stronger" - Old man Chu doesn't spawn - link

  • Sealed Solar Stone can't be unsealed - link

  • Can't continue Silversteel Storyline if you leave during Chapter 3 - link

  • Three-Point Landing (windwalking quest) doesn't work - link

Major bugs - 25 bugs

This is for the bugs that must be fixed, but aren't game breaking.
  • When swapping characters, you can get disconnected - link
    This bug exists since UE3, but wasn't as prevalent as it is now.

  • EU - Jinsoyun - "Failed to connect server. SystemErr - (100 : Web Authentication Failure)" - link
    This happens because the server takes too long to answer and the launcher craps out.
    If this happens, launch the game and wait...

  • Skills take a long time to trigger - link

  • Fullscreen options and resolution do not work - link

  • Tailored outfits can display an incorrect color - link
    Why isn't this a Visual bug? Because people may have paid for those outfits.
    Also, the Chromatic Threads can be bought with real money.
    This MUST be fixed!

  • Epic Challenge - Koldrak can get stuck at around 350k HP - link
    Koldrak will take VERY little damage, making the fight last over 10 minutes.

  • Holding the zoom in/out keys does nothing - link

  • When on Num-lock autowalk, the arrow keys rotate the camera and not the character - link

  • Cursor can click on things it shouldn't - link
    Why is this a Major bug?
    Well, this bug causes you to lose control of the game when, for example, changing a song or having a floating video to watch the raid mechanics.
    It isn't game breaking, but it can cause issues with raids and you can perform unintended operations on your pc, while playing, with the extremely unlikely possibility of loss of data and other damages.
    This happened in UE3, but shouldn't even happen in UE4...
    FPS games from 1995 fixed this issue!!!!!!! GO FUCKING READ STACKOVERFLOW AND FIX THIS!

  • PVP Arena is still slowing down after some matches - link
    After a few matches, the performance of the game starts suffering, running worse and worse...

  • When using Q and E and quick turn and SS, the SS will go in the wrong direction - link
    I've expanded the bug name, as I see this with other classes.

  • Skybreak Spyre - Moyun and Shun's floor has no effects - link
    Why isn't this in Visual bugs?
    If someone starts a boss by mistake, you can wipe the entire party and nobody will even know what happened.
    This is a major bug because of that, which is a huge waste of time for everybody.

  • Completed dailies show as incomplete in F8 - link
    The game is entirely built around dailies.
    If you don't know which ones you've done, you will end up doing repeated dailies for nothing.

  • Act VIII and Act X - The game still plays sounds when "Mute all" is enabled - link

  • Whirlwind Valley - When jumping over obstacles, you can get stuck on top - link

  • Turning the character with arrow keys, when a window is open, causes the camera to spin - link
    Related to bug " When on Num-lock autowalk, the arrow keys rotate the camera and not the character"

  • Loading game speed seems to be tied to FPS - link

  • Silverfrost Mountains - Zaiwei - Ebon Realm - NPC Dragon Trader Asimjin - Square gem trades are missing - link

  • Call for Arms - Stage 11 - The gems in the box do not have stats - link
    Additional information - link

  • Transmute - Heptagonal Tanzanite Pet Gem recipe is missing - link

  • Characters will long IGNs will be invisible in F8 - link

  • "Unable to send. The message is too long." shown when joining F8 with long IGN - link

  • Game freezes for multiple seconds when saving screenshots to an HDD in power saving mode - link

  • **EXTREMELY HIGH** number of page faults by the game - link

  • When starting the game, the background FPS value isn't respected - link

Class/Damage bugs - 22 bugs

All bugs that affect your ability to do damage will be reported here, separated by class.
This include gear stat bugs and bugs on performing skills and it's stats.

  • All classes

    • Heart buff is not being registered - link
  • Assassin

    • Ascension Stones [Choke Bomb/Night Reaver] (purple) doesn't apply to Shadow spec - link
  • Blade Dancer

    • Wind - IA Amulet still has Wind Slash skill - link
      Wind slash was removed with UE4

    • Lightning - Simple mode - Skills are missing from the F key - link

    • Lightning - Talent "Thunderbolts and Lightning" decreases the cooldown of Lightning Draw from 16 seconds to 19.2 seconds - link

    • Lightning - Simple mode - The V key is locked when in normal stance - link

    • Wind - Sometimes, Rolling Typhoon isn't available - link

    • Lightning - Skill "Bladeguard" has been re-added - link

    • Lightning - Skill "Flash Step" has been re-added - link

    • Lightning - Skill "Dual Strike" has been re-added - link

    • Lightning - Skill "Flash Step" can't be triggered in normal conditions - link
  • Blade Master

    • Spectral BM drops Deflect frequently but inconsistently - link
  • Destroyer

    • Earth - Cursed Surge does not proc at all on the Precipice Mystic Badge - link
  • Dual Blade

    • Can't open Skybreak Spire boxes - link
      When opening the box, you get an error saying "Invalid Item" - link

    • Simple mode - Decimator hidden on key 4 but skillpath shows the skill in the F key - link
  • Gunslinger - Gunner

    • Destruction Gunner Reaper talent's Awakened Bulletstorm does not give 5 Explosive Rounds on final hit while in Soul Burn/Soul Flare - link
  • Kung Fu Master

    • Grapple skill is usable on stunned, dazed, knocked down opponents - link
  • Summoner

    • When gliding, Familiar does very glitched and weird Gliding Animation - link
  • Warden

    • Lotus skill Illusion not working on warden - link
  • Warlock

    • Time Distortion stops working upon 2nd use - link

    • Time Distortion has wrong cooldown - link

    • Koldrak drains 60% to 80% of weapon durability - link

Minor bugs - 44 bugs

All bugs that don't really affect gameplay but should be fixed anyway.

  • Mythical Dungeon duplicate typo - link

  • Can't type and run anymore - link

  • Can't preview outfits from other players - link

  • Can't preview outfits inside boxes - link
    This bug exists since UE3!

  • Skill Illusions have Korean voice - link

  • Resurgence vouchers can't be sold on the "Manage Antiques" window - link

  • Game still freezes when opening screenshots - link
    This bug exists since UE3 - but now isn't as bad as before

  • Some dungeons/raids/weeklies are missing the windwalk button - link
    The link only refers to MSP, but other raids were found to have it missing - link

  • When changing regions, the models of the characters on the previous zone will stay outside the portal - link
    This also happens when changing channels or when the other character leaves the area - not reported in the forum

  • Screenshots no longer save with the current date and time, but with a number - link

  • Some windows don't close when you press ESC when the textbox is selected - link

  • Lucky revitalizers can't be used in solo dungeons - link

  • Crafting takes 1 minute to deliver something that takes 1 minute to craft - link

  • Chat settings only lets us set the font size in increments of 2 - link

  • Silverfrost Mountains - Zaiwei - Merchants Square - NPC Jun Suru is missing all trades - link

  • Battlegrounds - Indominable buff (25% damage reduction) is again active - link
    According to the post, this buff was removed a few patches ago

  • Gunwon City - Celestial Basin - Near the spawn, on the way to Scavengers' Excavation Site, the rocks get you stuck in the air - link

  • Gunwon City - Faircloud - The sharks are missing - link

  • Pressing enter confirms that you are ready, instead of opening the chat - link

  • When typing a message, pressing ESC deletes the contents - link

  • Excelent Elixir and Raid Revival Charms aren't usable in Scarlet Conservatory - link

  • Retrieving items from the mail box can stop midway - link
    Expanded the title as I've reproduced this bug by retrieving 15 items (which isn't a lot).

  • Viridian Coast - Jadestone Village - The map has a fishing spot, but there's nothing there - link

  • Khanda Vihar - Shrine of the Ascendant - Dawn of Khanda Vihar - Meganura doesn't wake up anymore - link

  • When searching for "square", the Dueler Square gems do not have "dueler" in the name - link
    Additional information - link

  • Sometimes, it is possible to be unable to move after watching a cutscene - link

  • Running over ledges can cause you to rubbedband and/or fall and take damage - link

  • Silverfrost Mountains - Zaiwei - South District - between Gossamer Inn and Cardinal Gates - portals do not work anymore - link

  • Viridian Coast - Jadestone Village - Running close to the wooden structure where the NPC Nagan is causes weird issues - link

  • Closing the Transmute window when a search was done, doesn't clear the results - link

  • Koldrak / Epic Challenge - Others' damage numbers show all bundled up, despite not being in the same party - link

  • Idle animations still happen during cutscenes - link

  • In the Dungeon Lobby, pressing enter doesn't open the chat - link

  • Moonwater Plains - Hogshead Pastures - Blackram East Fleet - Naryu Labyrinth - dragon pulse doesn't work - link

  • Awakened Tiger Soul Stage 2 - +33 Critical Damage% - link
    This doesn't happen for Stage 1 and Stage 3

  • Cathedra Cliffs - The vines have a new invisible wall - link

  • Cathedra Cliffs - The wall climb to Tanunga is wonky - link

  • Sometimes, the character selection screen fails to load all assets - link

  • If the "Epic Challenge" window is open, you can't get into Koldrak's Lair - link

  • Lunar Twilight Leaf's max stack size is 100 - link

  • Stonescale Passage - Amasa - If you SS and get Allurement while mid-animation, you walk backwards - link

  • When writing mail, the up and down keys don't move you between lines - link

  • House of Idols - Needler - if you jump into the left pillar, you will get stuck spinning in the air - link

  • Brood Chamber - Nacha - Flying against the invisible wall, at a certain point, causes you to be stuck in the air - link

Outfit, accessory and appearance bugs - 9 bugs

All non-major bugs related to outfits.

  • Galaxy Wings static and not moving like Steel Seraph/Iron Wings - link

  • Regium Corvus - female lyn - missing or clipping undergarments - link

  • Moon Hunter Orb shows as black and white - link

  • Demigod Adornment outfit - Cape completely black on all male characters - link

  • Inkbrush Skill Illusion - Dual Blade - Lotus spec - The skill illusion effects aren't applied - link

  • Hermit outfit - female lyn - has a line on the middle of the chest - link

  • Outfits are missing name - link

  • Custom Gangplank style - Weird color separation on the head - link

  • Collection "Something's Fishy" can't be finished - link

Visual bugs - 48 bugs

All bugs that are on walls, shadows, skills, effects and others will be added here.

  • Hidden players' effects are still visible - link

  • Shadow quality setting is broken - link

  • Outlaw Island - Standing behind a certain spot unloads the area too soon - link

  • Pet gems are on top of the pet preview - link

  • Alpha-blending for effects is incorrect on low settings - link

  • Tooltips do not have a background and/or border - link

  • Receiving mail causes some issues showing the background color of some items - link

  • The HP bar on the 2nd party, in an alliance, is bugged - link

  • Windrest - Fishing rod is missing animations - link

  • The cutscene (black) screen shows for too long - link

  • Flaming Scourge is visually bugged - link

  • The eyes behave weirdly when animated - link

  • Silverfrost Mountains - Grand Harvest Square - NPC stuck to stool T-poses to assert domination - link

  • Stonescale Passage - Missing textures for the mark - link

  • Being knocked down shows wrong icons randomly - link

  • Moonlight Skypetal Plains - Stage number is missing when stage is complete - link

  • Damage numbers from players that aren't anywhere near are still showing - link

  • "Phantom" characters show randomly - link

  • Outlaw Island - "Resurged Yeoharan" - animations seem to have some leftover contents - link

  • Gunwon City - Celestial basin - everything golden has turned into mossy-golden - link

  • Gunwon City - Celestial basin - The character has a green tint - link

  • Transcendent and Awakened stones are almost impossible to distinguish - link

  • Status icons with buffs/debuffs have weird sizes - link

  • Stonescale Passage - The monsters' weapons are missing textures, and not all despawn after being killed - link

  • When pressing CTRL-F, to show the previously hidden characters, can cause characters to do not have a body (sometimes don't have head) - link

  • Tower of Infinity - The enemy weapons are stuck on the floor - link

  • Getting close to an outlined object causes the outline to partially hide and become super thin - link

  • The order of the buffs and charms is reversed - link

  • Shattered masts - Last boss' anemone goes crazy after being killed - link

  • Ebondrake Citadel - "Smoke" behaves weirdly when the player is on the floor of the last boss - link

  • Viridian Coast - Jadestone village - Almost all houses have floating grass on the roof - link

  • When a character is in front of a chat buttle, from an NPC, it shows bits of sky(?) around the player - link

  • Silversteel Laboratory - Test Room Alpha - banners have EXTREMELLY bad quality - link

  • Ready check checkmarks have different colors between party 1 and party 2 - link

  • Solak - Ajanara Monastery - When leaving Circle of Sundering, the light is incorrect - link

  • When you zoom in too close, the body disappears, but the wings and weapon effects stay visible - link

  • House of Idols - Easy mode - killing the first mini boss while standing causes it to make an A-pose - link

  • Act 1 - Multiple bugs - link

  • Dasari Palace - Multiple bugs - link

  • Some dragon symbol, with 99% value, shows under the pet aura - link

  • In an auction (after finishing the dungeon), some items have Korean letters over the icon - link

  • Sandstorm Temple - taking the red dragon pulse causes issues loading assets on the map - link

  • Water causes corruption on the outline of objects we can interact with - link

  • Party 1's ultimate symbols still have the UE3 ultimate icons, while the party 2 has different ones - link

  • "Popups" that fade out lose the background color - link

  • Stonescale Passage - The wings on the Thornbreaker Greatsword turn into a rectangle when you have Petrified stacks - link

  • Cathedra Cliffs - If you die and press 4, and the cutscene to Ayana (Ayanka?) plays after you load, the cutscene will have missing assets - link

  • Brood Chamber - last boss - the circle isn't centered in the rest of the animated texture - link

Fixed bugs - 5 bugs

Here I will list all bugs that were fixed in the meantime.
But since I'm lazy, I will only list the bugs in this post.

Game breaking bugs - 2 bugs

Bugs that prevent you from playing, advancing on quests and others.
If it affects the ability to play the game, it will be here.

  • Players with AZERTY keyboard can't do skills - link
    Fixed on 15th September 2021

  • Text is unreadable - link (PARTIAL)
    The quantities have been changed to have a black border around the text, but it's still hard to read due to the size.
    PARTIALLY fixed on
    8th October 2021

Class/Damage bugs - 2 bugs

All bugs that affect your ability to do damage will be reported here, separated by class.
This include gear stat bugs and bugs on performing skills and it's stats.

Outfit, accessory and appearance bugs - 1 bug

All non-major bugs related to outfits.

  • Synthwave Illusion Twin Swords skin - When applied on Dual Blade, the animations are invisible - link
    Fixed on 8th October 2021
Last edited:
Not open for further replies.
Top Bottom