• Hi Guest! To get rid of ads on the page, please consider donating through user upgrades or other methods.

New Launcher does not allow non-steam add

Cîrjeu Daniel Marian

Cricket
Member
Yo!

Neither the new launcher or the bnsbuddy one allow the game to be added to Steam as a non-steam game, with Overlay and all that stuff.

Been using BnS as a non-steam game in my Steam library, and I also play it with the Steam Controller (so running it through Steam is a must).

The way I made it work was running Steam as administrator, and having "/LauncherID:"NCWest" /CompanyID:"12" /GameID:"BnS" /LUpdateAddr:"updater.nclauncher.ncsoft.com"" as launch options to the launcher, the way the shortcut is. To my knowledge there was no other way to do it, but this way I was able to use Steam, my friends were able to see I am in-game, was able to use the Steam Overlay and also to play using my Steam Controller, also in the Big Picture.



Now, with the new launcher, there is no possible way to do it. The only thing you can do is make people see you are in-game, but no Steam Controller or Steam Overlay possible. What I tried is making "C:\Program Files (x86)\NCSOFT\NC Launcher 2\Matryoshka.exe" a non-steam game with "/GameID:BnS" as launch options, but Steam believes the launcher is the game, not the game you will then launch from it. And it will think you are in-game for as long as the launcher is opened, even in System Tray, but Steam has nothing to do with the game itself.



If someone is able to find a way around this, please do inform me as well. Thanks!
 

Cîrjeu Daniel Marian

Cricket
Member
As an update, been asking everywhere and everyone, been trying everything possible, and what I did find out is that, with the new launcher, they completely disabled the steam overlay, they did something to block steam from accessing the game directly. At the moment there is no way to play with dedicated gamepad mode or Steam Overlay.

All you can do is let people see that you are in-game in BnS bei either creating a script and then making it an exe, and then run that exe as a non-steam game, or by launching Steam as admin and running the new launcher "C:\Program Files (x86)\NCSOFT\NC Launcher 2\Matryoshka.exe" with /GameID:BnS as launch options.

There is still a way to make Steam Controller work by changing the Desktop Configuration, but I refuse to do so because 1. the game will see it as KB+M and all buttons will not be shown as gamepad buttons and will be confusing af, and 2. I use the SC from bed while I watch Netflix and other stuff, don't want it to have KB binds.

Thanks, NCSoft!!!
 

KenJiTakana

Cricket
Donator
Member
As an update, been asking everywhere and everyone, been trying everything possible, and what I did find out is that, with the new launcher, they completely disabled the steam overlay, they did something to block steam from accessing the game directly. At the moment there is no way to play with dedicated gamepad mode or Steam Overlay.

All you can do is let people see that you are in-game in BnS bei either creating a script and then making it an exe, and then run that exe as a non-steam game, or by launching Steam as admin and running the new launcher "C:\Program Files (x86)\NCSOFT\NC Launcher 2\Matryoshka.exe" with /GameID:BnS as launch options.

There is still a way to make Steam Controller work by changing the Desktop Configuration, but I refuse to do so because 1. the game will see it as KB+M and all buttons will not be shown as gamepad buttons and will be confusing af, and 2. I use the SC from bed while I watch Netflix and other stuff, don't want it to have KB binds.

Thanks, NCSoft!!!
so you figured out how to launch the game through steam, but new problem is that it is using kb/m buttons instead of controller ?
 
Top Bottom