• Hi Guest! To get rid of ads on the page, please consider donating through user upgrades or other methods.

BNS settings resetting

Status
Not open for further replies.

Aorâ

Cricket
Member
hello , sorry if m posting this in the wrong place , do instruct me if i did
for a while my BNSbuddy settings have been resetting everytime i log into the program, the place where u select the server becomes blanc everytime and i have to switch it to EU , also the addons i have selected get unchecked everytime i start the program
i don't know uf that's normal , but it's a bit tedious to do that everytime i wanna play
 

cupid

Forgiving
Staff member
Moderator
Member
Can you send the clientsetting.xml file, located in documents/bns?

There is a bug in Blade and Soul where the settings reset if:
  • You sound card has ' in the name
  • You connect your pc to a tv for sound, where the device name has '
  • The sound device used for chat output has ' in the name
 

cupid

Forgiving
Staff member
Moderator
Member
On line 43, you have this:
HTML:
<option name='audio-device' value='Haut-parleurs (Realtek High Definition Audio)'/>

And on line 238, you have this:
HTML:
<option name='voice-chat-output-device' value='Haut-parleurs (Realtek High Def'/>

Try manually changing that line to have the same value.
Please, report back with your results.
 

Aorâ

Cricket
Member
i put the two lines into the same value
'Haut-parleurs (Realtek High Definition Audio)'

started bnsbuddy and the game for a bit , exited from everything , ran bnsbuddy again , but everything had reset , didn't fix it
 

cupid

Forgiving
Staff member
Moderator
Member
i put the two lines into the same value
'Haut-parleurs (Realtek High Definition Audio)'

started bnsbuddy and the game for a bit , exited from everything , ran bnsbuddy again , but everything had reset , didn't fix it

Then there's something else that I didn't see.

Can you send the same file, but after you close the game?
And after you login?

I want to compare both, and see if there's any difference.
 

Aorâ

Cricket
Member
there
 

Attachments

  • ClientConfiguration out of the game.rar
    11.1 KB · Views: 11
  • ClientConfiguration while ingame.rar
    11.1 KB · Views: 8

vuyukia

Cricket
Member
actually have the exactly the same problem everything resets except key bindings and my headset is razer man of war
 

cupid

Forgiving
Staff member
Moderator
Member
actually have the exactly the same problem everything resets except key bindings and my headset is razer man of war

Razer ManO'War (https://www.razer.com/gaming-audio/razer-manowar) has ' in the name, which causes the issue.
You are the 3rd person I've seen with that headset.

The only fix is to use a virtual cable software and set the audio device to it.
It is a pita to setup, but works flawlessly.

If you do streaming, it gives huge control over the audio and what people can(n't) hear.
--- Merged ---

https://www.diffchecker.com/bKJon3WG

Both files are exactly the same.
Both have the broken line 238:
HTML:
<option name='voice-chat-output-device' value='Haut-parleurs (Realtek High Def'/>

I doubt we can do much (the ManO'War headset is an example where there's a workaround) about it.

I kinda would try the solution suggested there.
(https://www.bnsbuddy.com/threads/bns-settings-resetting.658/#post-3083)
 

Unknow

Cricket
Member
Hello i have the same problem, i've try to modify in documents/bns the
"<option name='audio-device' value='Haut-parleurs (Realtek High Definition Audio)'/>"
but it didn't work.
I'm using a Logitech headset. I also added my ClientConfiguration in case.
 

Attachments

  • ClientConfiguration.rar
    11.7 KB · Views: 12

cupid

Forgiving
Staff member
Moderator
Member
Hello i have the same problem, i've try to modify in documents/bns the

but it didn't work.
I'm using a Logitech headset. I also added my ClientConfiguration in case.

I've noticed that both of you are french.

Lots of french text uses '.
The game doesn't convert ' into the correct entity (but does convert & into &amp;).

Maybe it is something related to your language or keys?
For example, if you try to use the ' key for skills or something.
 

Aorâ

Cricket
Member
i didn't always have this issue though , it started happning just after bnsbuddy a couple of times
 

Unknow

Cricket
Member
I've noticed that both of you are french.

Lots of french text uses '.
The game doesn't convert ' into the correct entity (but does convert & into &amp;).

Maybe it is something related to your language or keys?
For example, if you try to use the ' key for skills or something.

Hello, well a lot of my mates are french aswell and have the same stuff as me but don't have this problem so idk.
 

cupid

Forgiving
Staff member
Moderator
Member
i didn't always have this issue though , it started happning just after bnsbuddy a couple of times

I'm 999999% sure it isn't BnSBuddy.
That file isn't used at all.

Only BnS uses that file.
--- Merged ---
Hello, well a lot of my mates are french aswell and have the same stuff as me but don't have this problem so idk.

The only thing I see wrong with all the files is the soundcard name.
Except on yours, but yours is french as well... So, I'm confused.
 

Unknow

Cricket
Member
I'm 999999% sure it isn't BnSBuddy.
That file isn't used at all.

Only BnS uses that file.
--- Merged ---


The only thing I see wrong with all the files is the soundcard name.
Except on yours, but yours is french as well... So, I'm confused.
Well, the weirdest thing is that it only happens to me from yesterday-todays, never happens to me before and i was using the same headset etc...
Weird.
Also my bnsbuddy is doing like this :
For the mods it goes to F:\BnS\contents\Local\NCWEST\FRENCH
and my addons are located at : F:\BnS Mod\BnsBuddy\addons
 

cupid

Forgiving
Staff member
Moderator
Member
Hello, well a lot of my mates are french aswell and have the same stuff as me but don't have this problem so idk.
Well, the weirdest thing is that it only happens to me from yesterday-todays, never happens to me before and i was using the same headset etc...
Weird.
Also my bnsbuddy is doing like this :
For the mods it goes to F:\BnS\contents\Local\NCWEST\FRENCH
and my addons are located at : F:\BnS Mod\BnsBuddy\addons

That is normal.

You can, however, change the mod folder path in the settings tab (not sure which page).
Except for the mods installed, which MUST be in F:\BnS\contents\Local\NCWEST\FRENCH
 

Aorâ

Cricket
Member
i re installed bnsbuddy more than once and didn't help ;-; guess i'll have to live with this , feelsbadman
 

cupid

Forgiving
Staff member
Moderator
Member
i re installed bnsbuddy more than once and didn't help ;-; guess i'll have to live with this , feelsbadman

IT'S NOT BNSBUDDY!!!!!!

I TOLD YOU THIS BEFORE!

BNSBUDDY DOESN'T TOUCH IN ANY WAY, SHAPE OR FORM THE CLIENTCONFIGURATION.XML FILE!


What you're doing won't do anything.

Just try the file repair.

If you don't believe me, read the source code: https://github.com/RedDot-3ND7355/BnS-Buddy
 

Aorâ

Cricket
Member
i did not say it was bns buddy fault or m not believing you , m just saying that i have tried everything and nothing worked
repaired game files , did the change line thingy in the config file u told me about
re installed bnsbuddy totally
i don't see anything else i can do except reinstal window or download the whole game from 0 lel
 
Status
Not open for further replies.
Top Bottom